Mobile issue with story icons and page slowness

I’ve been reading GSS stories on my phone a lot lately, and I had noticed that the pages get slow – almost to the point of freezing up – when there are story icons present (for high rated stories, which is especially true for my favorited or bookmarked pages). If there’s no story icons, it’s not slow and doesn’t stutter at all. If there are, it’s very unresponsive until they disappear from the page due to finally managing to scroll past them.

I’m using Android and Chrome on my Pixel 6 phone, if that matters.

(As with any site feedback I give, I am not criticizing at all, just trying to give actual feedback)

You can activate the “Disable pulsing” option (under Themes).

What phone do you have if I may ask?

(Am I coming across as that sensitive, so everyone sees the need to explicitly stress that they’re not criticizing me or the site? If that’s the image people have of me, I seriously have to overthink my presentation… :wink: )

I’ve got a Pixel Pro 6 – android

And no, not at all on the sensitivity, I almost always put in a disclaimer like that in case I come off wrong :slight_smile:

I’ll try the pulse off setting and let you know!

Ok, I disabled pulsing and that didn’t help, alas. :slight_smile:

Hm, strange.

You’re saying that this also affects your favorite or bookmark list, which already has a limited size. How many entries are you listing (at the bottom you can set how many entries per page should be listed).

Your phone should be more than capable!

It also affects author story list pages (I know, because I’m going through Touchstone’s at the moment) for me.

I had it set at 200, but I just changed it to 10 and it’s still stuttery / slow if icons are showing. And again, if the icons aren’t present on the screen (if I’ve scrolled into an area with stories that have no icons) it’s smooth.

Even though they’re not pulsing?

What browser are you using? Does anyone else experience similar problems?

I’m using Chrome (the default browser for Android/Pixel phones). I did just check and see if there was an update for Chrome for it, but I’m up-to-date. And I’m also up-to-date on the latest Android version.

And I just tried a few other themes in case it was the default Slate/Dark that was the problem, but no such luck, it stutters on every theme. And confirmed, it’s not pulsing / pulsing is disabled.

I’ve had problems using the site in general, as the loading has been awfully slow for days now. But I’m pretty sure it’s not the site itself, it’s my provider’s connection to the US AWS backbone which is somehow really slow. I had that problem in the past, but it always disappeared after a day or two. Now it seems to persist… :frowning:

As for the problem you’re describing, I can somewhat reproduce it. I also know that it used to be working way better. It seems that some update of the Chrome renderer has introduced that issue.

When testing, the “disable pulsing” option did make a difference though, the stuttering is still there, just not to the same extent.

I don’t see any way to improve the issue other than to disable the icons altogether. Of course, I could change them to make their rendering less demanding (I actually know what causes the issue), but that would be a more elaborate change.

So please, everyone who reads this, how much does this affect you? Does it make the experience unpleasant for you? Or is it something you can live with?

TBH, it hits me pretty hard, as much as it pains me to say it. And I love those icons too, they’re extremely useful for me!

(I’ll keep pulse disabled though, that was a good’n)

The site has also been loading very slowly for me for about a week. It was much faster before.

May I ask from where you’re accessing the site from?

I suspect that it might be a very specific problem with the connection from Europe (possibly the Telekom backbone) to the AWS eastern US network, where our sites are located.

The reason for my suspicion is that the pages of AWS itself are also loading very slowly.

I’m from Germany and my internet provider is Telekom. Then you’re probably right and it has something to do with that.

1 Like

Yeah, exactly the same configuration as me. Thanks for confirming my theory!

Ok, the issue is the multi-layered shadows the badges are using to create that glowing effect. They used to work great on mobiles, but I guess, they dialed down the hardware resources the renderer is permitted to use to save battery capacity.

I’ve played around a bit if I can reduce some layers, but the results were always less than satisfactory.

The only option I’d have would be to use static images instead of vector graphics with shadow layers, which I’m currently using. But that would mean some larger changes on my part, as well as a less than satisfactory result.

I know it’s a bit inconvenient for now, but as there’s no simple solution, it’s going to have to stay like this for the time being. Sorry.

1 Like

Thanks for having a go, appreciate the effort

1 Like

Läuft jetzt seit ein paar Tagen wieder wie geschmiert bei mir :+1: Bei dir auch?

It seems that Telekom has fixed it. Haven’t had any trouble loading the page for a few days now :upside_down_face:

Yes, it’s working as usual now, just like you said, it seems they fixed it a couple of days ago.

This was not the first time I experienced this slowness in the connection to certain parts of the US. It seems that there is a backbone issue between the German Telekom and the US which keeps coming up from time to time. This is disconcerting, as it also affects some of my favorite (porn) sites … :blush:

I’ve been having issues with this ever since the pulsing icons were introduced. Marking disable pulsing helps SOME but there are still issues because it doesn’t affect the icons next to author names, which continue pulsing regardless. I’m mobile the majority of the time so the site has been completely unusable for me for a while now and that’s very disappointing :pensive: